It is currently 28 February 2021, 3:28 Advanced search

Custom report size does not work when published

Questions and answers on how to best use Instant Developer

Custom report size does not work when published

Postby ATroyer » 12 August 2020, 18:42

I have a set of reports that I wish to print on US letter-size paper. Knowing that INDE works better with mm, I set the paper size to 215.9 mm x 279.4 mm, the equivalent of 8-1/2" x 11" in landscape format. Compiling the app locally works fine; I can download and print the reports perfectly well. However, when I published online, the report fields became a jumbled mess. I tried both Chrome and Firefox browsers; both worked fine with the local version and both did horribly online. I suspect that the published version is looking for A4 paper or something, but I have no idea why, since it works fine locally. The two attachments have identical data, since they are connected to the same online database. (The red stripe is actually a background image; all background images print the same, whether online or local.) I also see that normal text looks the same in both versions, but italics are much more slanted in the jumbled version.
Attachments
Report jumbled.jpg
Report jumbled.jpg (167.07 KiB) Viewed 670 times
Report Correct.jpg
Report Correct.jpg (167.69 KiB) Viewed 670 times
ATroyer
 
Posts: 19
Joined: 30 October 2019, 13:30

Re: Custom report size does not work when published

Postby ATroyer » 12 August 2020, 18:46

The same applies to the first page of the reports. Again, the background image is fine either way.
Attachments
front jumbled.jpg
front jumbled.jpg (192.48 KiB) Viewed 669 times
front regular.jpg
front regular.jpg (197.63 KiB) Viewed 669 times
ATroyer
 
Posts: 19
Joined: 30 October 2019, 13:30

Re: Custom report size does not work when published

Postby lucabaldini » 13 August 2020, 14:44

I don't know if that's the problem but I suspect there is something wrong with fonts... Are you sure that on the server there are the same fonts that you have locally on your PC? At least the fonts the book is using...
User avatar
lucabaldini
Pro Gamma
Pro Gamma
 
Posts: 4689
Joined: 1 October 2010, 17:03
Location: Bologna

Re: Custom report size does not work when published

Postby ATroyer » 14 August 2020, 16:11

Yes, the problem was fonts. It took a while, and I asked LJ Wilson for a hand. Eventually, this worked along with placing the fonts in the custom folder. Thanks
Attachments
Untitled.png
Untitled.png (10.11 KiB) Viewed 623 times
ATroyer
 
Posts: 19
Joined: 30 October 2019, 13:30

Re: Custom report size does not work when published

Postby ljwilson » 14 August 2020, 18:38

And for completeness, here is the GetPathDelimiter function:
2020-08-14_14-36-50.png
2020-08-14_14-36-50.png (13.55 KiB) Viewed 618 times


...jack
ljwilson
 
Posts: 559
Joined: 26 November 2013, 14:15

Re: Custom report size does not work when published

Postby lucabaldini » 17 August 2020, 7:53

Glad it helped. :-)))))))))))
User avatar
lucabaldini
Pro Gamma
Pro Gamma
 
Posts: 4689
Joined: 1 October 2010, 17:03
Location: Bologna


Return to Tips & Tricks

Who is online

Users browsing this forum: No registered users and 7 guests

cron